Here you can download Untis and Untis Express 2015:


Untis is available in many languages. Please select the language you need.

language


Important information for installation

As of Untis 2014, .NET Technology is used, i.e. the respective framework needs to be installed at all computers which run Untis. When installing Untis, .NET Framework is automatically installed. If you install Untis 2015 on a server and only give the individual clients access to Untis.exe then you need to make sure that the clients also have .NET Framework installed (version 4.0).

Please download the installation files of .NET Framework here:: dotNetFx40_Full_x86_x64.exe

minimum requirements: Windows XP SP 3


version brochure

The latest version brochure for Untis 2015 is available in the download area.

or open here.:


Newsletter

Always stay informed